Capture One Pro 20 and Catalina issue

Hey all-

Just updated to C1P20, and I’m running the latest version of Catalina. The program isn’t recognizing my camera for tethered work, saying No Camera Connected. I’ve given the program full access of my computer via Accessibility and Full Disk Access. I’ve created a new user on my OS and tried that with no luck. I’ve reset permissions via Terminal and the code from C1P’s website. I’ve restarted both the program and my computer. Everything worked a few days ago while on C1P12. I’m on a Nikon D750. Anyone else run into this and found a way to fix it?

Hey Dan,

Hm… seems I remember in PI you had some issues connecting at one point. Can’t remember then what the solution was. Try this: Connect camera, turn it on, go to Apple > About my Mac > System Report find the USB bus in the list to the left, and click on it and see if it lists your camera as a device that is being ‘seen’ so to speak, by the computer. If the computer sees the camera, that means the cable is fine, and it’s a C1Pro thing, if not, then it’s likely the cable.
Have you scoped the C1Pro forums to see if this issue exists for other D750 users?
Have you hit up the C1Pro Facebook group (Capture One’s David Grover stalks it and sometimes will answer questions).
Have you gone to C1Pro>Preferences>Updates and checked for update to see if it’s a glitch that has been ironed out?
When you hit up the forums/FB groups, come armed with the exact C1P20 version number and the exact Catalina OS number and lead with that information.
I’d first see if it’s computer or software that is the issue - then I’d hit up the forums and FB group.
Best of luck! Wish I had the one-button fix on this one for ya!

Also see if there are any latest firmware updates for your D750.
And here’s the link to the FB group

Thanks Jeff! Good memory on the C1P issues I had :slight_smile:

I followed the instructions on C1’s website to do a complete uninstall/reinstall, and now it’s up and running, which is great, cause I had to use LR’s tethered option for a shoot yesterday, and that’s just not fun at all.